Forum Settings
       
Reply To Thread

Direct X PROBLEMFollow

#1 Feb 05 2011 at 12:22 PM Rating: Decent
6 posts
hi all im trying to play rift but it says i need to update my directx , but when i try it wont let me , also when i go to microsoft website to do it there the site says page canot be displayed when i try to download it , but its fine when i try to do it on my laptop .. please if you can help or give me any idea on how to fix it i would be gratefull thank you
#2 Feb 05 2011 at 3:53 PM Rating: Decent
Repressed Memories
******
20,908 posts
You can try an alternate download source. Directx 9c is what you need.
#3 Feb 05 2011 at 4:30 PM Rating: Decent
6 posts
stil doesnt work :( but thanks anyway
#4 Feb 05 2011 at 4:49 PM Rating: Good
are you sure you need to update?

On windows XP you can go Start > Run > type dxdiag.
That box on the 1st tab at the bottom will tell you what version you have.

If on Windows 7 you can do Window Key + R to get the Run box to show, then type dxdiag.

(If you are on vista, I dunno..I skipped that version).
____________________________
Sandinmyeye | |Tsukaremashi*a |
#5 Feb 05 2011 at 5:28 PM Rating: Decent
6 posts
yes im on directx 11 :/ but when i load rift it says ("we detected one or more DirectX components are out of date! would you like to update now?") so then i try that and it doesnt work it starts to instal then comes up saying ("Setup could not download the file please retry later or check network connection")
#6 Feb 05 2011 at 6:58 PM Rating: Good
So what happens when you click NO?

Last week in beta every time I would load the game it would tell me my Video Drivers were out of date and needed to be updated or else the game may not run right.
They were (and are) up-to-date. So you could be getting a Beta Bug that is a false positive.
____________________________
Sandinmyeye | |Tsukaremashi*a |
#7 Feb 05 2011 at 7:12 PM Rating: Decent
6 posts
it just closes and wont load up
#8 Feb 05 2011 at 7:21 PM Rating: Good
hm. The only thing I can say is to check your network connection?
Make sure the right stuff is being allowed?
Seems odd you can start the download, and then it crashes.

This page doesn't load you say?
____________________________
Sandinmyeye | |Tsukaremashi*a |
#9 Feb 05 2011 at 7:30 PM Rating: Decent
6 posts
it just closes and wont load up
#10 Feb 06 2011 at 5:02 AM Rating: Decent
6 posts
ye that one does and the next one does but soon as i click the download it says unable to connect :/.
#11 Feb 07 2011 at 10:24 AM Rating: Decent
4 posts
Go to microsoft.com and download the DirectX redistributable package, not the web installer:

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3b170b25-abab-4bc3-ae91-50ceb6d8fa8d

Be sure to run it as administrator. Should solve most problems.
#12 Feb 15 2011 at 10:23 PM Rating: Decent
1 post
If you still get error when installing with the redist the above poster posted, reboot your system into Safe Mode and try install it. Worked for me.
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 31 All times are in CDT
Anonymous Guests (31)